--- title: "Data Design" slug: "nimoro-studio-data-manage-data-design-vpc" updated: 2026-09-17T09:29:55Z published: 2026-09-17T09:29:55Z canonical: "guide.ncloud-docs.com/nimoro-studio-data-manage-data-design-vpc" --- > ## Documentation Index > Fetch the complete documentation index at: https://guide.ncloud-docs.com/llms.txt > Use this file to discover all available pages before exploring further. # Data Design **最新のコンテンツが反映されていません。早急にアップデート内容をご提供できるよう努めております。最新のコンテンツ内容は韓国語ページをご参照ください。** VPC 환경에서 이용 가능합니다. NIMORO에 연동된 서비스 데이터 중 리포트의 소스로 사용할 테이블을 불러와 데이터 디자인(Data Design)으로 구성하고 관리하는 방법을 설명합니다. 리포트에서 데이터 소스로 사용할 디멘션(Dimension)과 KPI 컬럼을 정하여 생성해 둔 태그를 연결하거나 필요한 코드 그룹(Code Group)을 연결할 수 있습니다. 코드 그룹을 소스가 되는 컬럼과 같이 사용하여 사용자가 리포트를 분석 및 활용할 수 있으며, 생성된 태그를 통해 소스가 되는 컬럼을 사용할 디멘션 또는 KPI별로 정의하여 리포트에서 활용할 수 있습니다. 참고 NIMORO에서 데이터 디자인 생성을 위해서는 물리 데이터 테이블을 활용할 수 있는 데이터베이스에 데이터를 저장하고, NIMORO에 해당 테이블에 대한 접근 권한을 허용해야 합니다. Trino 커넥터가 반드시 생성되어 있어야 합니다. ## Data Design 화면 Data Design 화면은 다음과 같이 구성되어 있습니다. ![nimoro-studio-data-manage-data-design-vpc_screen_ko](https://cdn.document360.io/6998976f-9d95-4df8-b847-d375892b92c2/Images/Documentation/nimoro-studio-data-manage-data-design-vpc_screen_ko.png?sv=2026-02-06&spr=https&st=2026-10-26T17%3A11%3A30Z&se=2026-10-26T18%3A11%3A30Z&sr=c&sp=r&sig=7oLXosdrat6EJblJYMtqAZHBR45J47jNGCUmttNr%2B4U%3D) | 영역 | 설명 | | --- | --- | | ① 메뉴 영역 | 현재 확인 중인 메뉴 이름 및 설명 | | ② 검색 필터 | - 데이터베이스 이름으로 선택 또는 검색하여 필터링 - 데이터 디자인 이름 또는 테이블 이름으로 검색하여 필터링 | | ③ **CREATE DATA DESIGN** | 클릭 시 [데이터 디자인 생성](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EB%8D%B0%EC%9D%B4%ED%84%B0%EB%94%94%EC%9E%90%EC%9D%B8%EC%83%9D%EC%84%B1) | | ④ 데이터 디자인 목록 | 전체 데이터 디자인 목록 조회 - **ID**: 데이터 디자인 목록 번호 - **Data Design Name**: 데이터 디자인 이름 - **Catalog.Database.Table**: 연결된 Data Catalog 서비스의 데이터베이스의 테이블 이름 - **Descriptions**: 데이터 디자인 설명 - **Report**: 해당 데이터 디자인에 연결된 리포트 개수 - **Last Edited**: 마지막 수정 일시(yyyy-mm-dd hh:mm:ss) 및 사용자 이름 - **Last Deployed**: 마지막 배포 일시(yyyy-mm-dd), 배포 버전 정보 및 사용자 이름 | | ⑤ 추가 기능 | 데이터 디자인 수정 및 삭제 - ![i-nimoro_edit](https://cdn.document360.io/6998976f-9d95-4df8-b847-d375892b92c2/Images/Documentation/i-nimoro_edit.png?sv=2026-02-06&spr=https&st=2026-10-26T17%3A11%3A30Z&se=2026-10-26T18%3A11%3A30Z&sr=c&sp=r&sig=7oLXosdrat6EJblJYMtqAZHBR45J47jNGCUmttNr%2B4U%3D): 클릭 시 [데이터 디자인 수정](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EB%8D%B0%EC%9D%B4%ED%84%B0%EB%94%94%EC%9E%90%EC%9D%B8%EC%A0%95%EB%B3%B4%EC%88%98%EC%A0%95) 가능 - ![i-nimoro_more](https://cdn.document360.io/6998976f-9d95-4df8-b847-d375892b92c2/Images/Documentation/i-nimoro_more.png?sv=2026-02-06&spr=https&st=2026-10-26T17%3A11%3A30Z&se=2026-10-26T18%3A11%3A30Z&sr=c&sp=r&sig=7oLXosdrat6EJblJYMtqAZHBR45J47jNGCUmttNr%2B4U%3D): 클릭 시 [데이터 디자인 삭제](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EB%8D%B0%EC%9D%B4%ED%84%B0%EB%94%94%EC%9E%90%EC%9D%B8%EC%82%AD%EC%A0%9C) | ## 데이터 디자인 생성 데이터 디자인은 다음 2가지 방식으로 생성할 수 있습니다. - [외부 DB에서 가져와서 생성](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EC%99%B8%EB%B6%80DB%EC%97%90%EC%84%9C%EA%B0%80%EC%A0%B8%EC%99%80%EC%84%9C%EC%83%9D%EC%84%B1): 실제 물리 테이블을 활용하여 데이터 테이블을 직접 불러와서 데이터 디자인을 생성합니다. - [쿼리로 작성하여 생성](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EC%BF%BC%EB%A6%AC%EB%A1%9C%EC%9E%91%EC%84%B1%ED%95%98%EC%97%AC%EC%83%9D%EC%84%B1): 쿼리를 직접 작성하여 데이터 디자인을 생성합니다. ### 외부 DB에서 가져와서 생성 외부 데이터베이스 테이블을 직접 불러와서 데이터 디자인을 생성하는 방법은 다음과 같습니다. 1. NIMORO 플랫폼에 접속해 주십시오.([NIMORO 플랫폼 접속](/docs/nimoro-access-vpc#NIMORO%ED%94%8C%EB%9E%AB%ED%8F%BC%EC%A0%91%EC%86%8D) 참조) 2. 좌측 메뉴에서 ![i-nimoro_studio](https://cdn.document360.io/6998976f-9d95-4df8-b847-d375892b92c2/Images/Documentation/i-nimoro_studio.png?sv=2026-02-06&spr=https&st=2026-10-26T17%3A11%3A30Z&se=2026-10-26T18%3A11%3A30Z&sr=c&sp=r&sig=7oLXosdrat6EJblJYMtqAZHBR45J47jNGCUmttNr%2B4U%3D)(NIMORO Studio)을 클릭해 주십시오. 3. **Data Manage > Data Design** 메뉴를 차례대로 클릭해 주십시오. 4. **[CREATE DATA DESIGN] > [외부 DB에서 가져와서 만들기]** 버튼을 차례대로 클릭해 주십시오. 5. 데이터 디자인 생성 팝업 창이 나타나면 다음 순서에 따라 정보를 선택 및 입력해 주십시오. - **Step 1. Connector**: 사용자가 생성한 커넥터 중 Trino 커넥터 선택 - **Step 2. Database**: Trino 커넥터 카탈로그에 생성된 데이터베이스 선택 - 검색창: 데이터베이스 이름으로 검색 후 선택 가능 - **Step 3. Table List**: 데이터베이스에 속한 테이블 목록 중 리포트에 사용할 테이블 선택 - **Step 4. Selected Table**: Step 3에서 선택한 테이블 목록 조회 - 선택한 테이블별로 데이터 디자인 생성(2개의 테이블 선택 시 데이터 디자인도 2개 생성) - **No**: 테이블 목록 번호 - **Catalog.Database.Table**: 연결된 Data Catalog 서비스의 데이터베이스의 테이블 이름 - **Data Design Name**: 생성할 데이터 디자인 이름 입력 - 미입력 시 {Database 이름}.{Table 이름}으로 설정됩니다. - 이름은 중복이 불가하고 생성 후 수정할 수 있으며, 최대 100자까지 입력할 수 있습니다. - 모든 문자열을 입력할 수 있습니다. - ![i-nimoro_delete](https://cdn.document360.io/6998976f-9d95-4df8-b847-d375892b92c2/Images/Documentation/i-nimoro_delete.png?sv=2026-02-06&spr=https&st=2026-10-26T17%3A11%3A30Z&se=2026-10-26T18%3A11%3A30Z&sr=c&sp=r&sig=7oLXosdrat6EJblJYMtqAZHBR45J47jNGCUmttNr%2B4U%3D): 클릭하여 테이블 삭제 6. **[IMPORT]** 버튼을 클릭해 주십시오. 7. 데이터 디자인 컬럼 정보를 설정해 주십시오. - 자세한 내용은 [데이터 디자인 컬럼 수정](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EB%8D%B0%EC%9D%B4%ED%84%B0%EB%94%94%EC%9E%90%EC%9D%B8%EC%BB%AC%EB%9F%BC%EC%88%98%EC%A0%95)을 참조해 주십시오. ### 쿼리로 작성하여 생성 쿼리를 직접 작성하여 데이터 디자인을 생성하는 방법은 다음과 같습니다. 1. NIMORO 플랫폼에 접속해 주십시오.([NIMORO 플랫폼 접속](/docs/nimoro-access-vpc#NIMORO%ED%94%8C%EB%9E%AB%ED%8F%BC%EC%A0%91%EC%86%8D) 참조) 2. 좌측 메뉴에서 ![i-nimoro_studio](https://cdn.document360.io/6998976f-9d95-4df8-b847-d375892b92c2/Images/Documentation/i-nimoro_studio.png?sv=2026-02-06&spr=https&st=2026-10-26T17%3A11%3A30Z&se=2026-10-26T18%3A11%3A30Z&sr=c&sp=r&sig=7oLXosdrat6EJblJYMtqAZHBR45J47jNGCUmttNr%2B4U%3D)(NIMORO Studio)을 클릭해 주십시오. 3. **Data Manage > Data Design** 메뉴를 차례대로 클릭해 주십시오. 4. **[CREATE DATA DESIGN] > [Query로 Data Design 만들기]** 버튼을 차례대로 클릭해 주십시오. 5. 데이터 디자인 생성 팝업 창이 나타나면 정보를 입력해 주십시오. - **Data Design Name**: 생성할 데이터 디자인 이름 입력 - 이름은 중복이 불가하고 생성 후 수정할 수 있으며, 최대 100자까지 입력할 수 있습니다. - 모든 문자열을 입력할 수 있습니다. - **Descriptions**: 생성할 데이터 디자인 설명 입력 - 최대 500자까지 입력할 수 있습니다. 6. **[CREATE AND MAKE QUERY]** 버튼을 클릭해 주십시오. 7. 데이터 디자인 수정 및 쿼리 입력 화면이 나타나면 다음 단계를 차례대로 진행해 주십시오. - [1. 데이터 테이블 불러오기(Import Data Table)](/docs/ja/nimoro-studio-data-manage-data-design-vpc#1%EB%8D%B0%EC%9D%B4%ED%84%B0%ED%85%8C%EC%9D%B4%EB%B8%94%EB%B6%88%EB%9F%AC%EC%98%A4%EA%B8%B0ImportDataTable) - [2. 데이터 디자인 컬럼 정보 설정(Set Data Column)](/docs/ja/nimoro-studio-data-manage-data-design-vpc#2%EB%8D%B0%EC%9D%B4%ED%84%B0%EB%94%94%EC%9E%90%EC%9D%B8%EC%BB%AC%EB%9F%BC%EC%A0%95%EB%B3%B4%EC%84%A4%EC%A0%95SetDataColumn) #### 1. 데이터 테이블 불러오기(Import Data Table) 데이터 테이블을 불러오는 방법은 다음과 같습니다. 1. 데이터 테이블에 대한 기본 정보를 조회해 주십시오. - 데이터 디자인 정보 - 데이터 디자인 이름 - **[DATA 조건 전체보기]** 버튼: 클릭하여 [데이터 디자인 전제 조건 조회 및 수정](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EB%8D%B0%EC%9D%B4%ED%84%B0%EB%94%94%EC%9E%90%EC%9D%B8%EC%A0%84%EC%A0%9C%EC%A1%B0%EA%B1%B4%EC%A1%B0%ED%9A%8C%EB%B0%8F%EC%88%98%EC%A0%95) - 추가 기능: 클릭하여 [데이터 디자인 정보 수정](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EB%8D%B0%EC%9D%B4%ED%84%B0%EB%94%94%EC%9E%90%EC%9D%B8%EC%A0%95%EB%B3%B4%EC%88%98%EC%A0%95), [데이터 디자인 삭제](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EB%8D%B0%EC%9D%B4%ED%84%B0%EB%94%94%EC%9E%90%EC%9D%B8%EC%82%AD%EC%A0%9C) - **Connector**: 커넥터 종류 - **Catalog.DB.Table**: 연결된 Data Catalog 서비스의 데이터베이스의 테이블 이름 - **ID**: 데이터 디자인 목록 번호 - **Creation Type**: 데이터 디자인 생성 방식 - **Import Table**: [외부 DB에서 가져와서 생성](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EC%99%B8%EB%B6%80DB%EC%97%90%EC%84%9C%EA%B0%80%EC%A0%B8%EC%99%80%EC%84%9C%EC%83%9D%EC%84%B1) - **Import Table with Query**: [쿼리로 작성하여 생성](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EC%BF%BC%EB%A6%AC%EB%A1%9C%EC%9E%91%EC%84%B1%ED%95%98%EC%97%AC%EC%83%9D%EC%84%B1) - **Created**: 데이터 디자인 생성 일시(yyyy-mm-dd hh:mm:ss) 및 생성자 이름 - **Last Edited**: 데이터 디자인 마지막 수정 일시(yyyy-mm-dd hh:mm:ss) 및 수정자 이름 - **Last Deployed**: 데이터 디자인 마지막 배포 일시(yyyy-mm-dd hh:mm:ss) 및 배포자 이름 - **Description**: 데이터 디자인 설명 - **Reports Using This**: 해당 데이터 디자인을 사용 중인 리포트 개수 2. 쿼리로 데이터 테이블을 불러온 후 **[APPLY]** 버튼을 클릭해 주십시오. - **Import Data Table with Query** - **Connector**: 사용자가 생성한 커넥터 중 Trino 커넥터 선택 - **Query 입력**: 불러올 데이터 테이블 쿼리 입력 - **@ Parameter**: 클릭하여 사용 가능한 파라미터 목록 및 설명 확인 - 분석 목적에 따라 여러 데이터베이스에 있는 테이블을 조합하여 분석용 조회 테이블(View Table)을 구성해 하나의 데이터 디자인으로 생성할 수 있습니다. - 쿼리에 파라미터를 사용하면, 해당 데이터 디자인을 활용하는 리포트마다 각각 다른 조건값으로 소스 필터 조건을 적용할 수 있습니다. - 동일한 이름의 파라미터는 동일 값으로 인식하여 리포트에서 필터 조건 값 입력 시 일괄적으로 치환됩니다. - 시스템 파라미터에 대한 자세한 내용은 [Data Design Parameter](/docs/nimoro-studio-data-manage-data-design-parameter-vpc) 를 참조해 주십시오. 3. 파라미터 쿼리 유효성 검사를 실행하고 조건에 맞는 데이터가 조회되는지 확인한 후 **[QUERY CHECK]** 버튼을 클릭해 주십시오. - **Set Parameter** - **No**: 파라미터 목록 번호 - **Parameter**: 파라미터 이름 - **Value**: 쿼리 유효성을 검사할 파라미터 값 입력 - 입력 값을 초기화하려면 **[Reset]** 버튼을 클릭해 주십시오. - 시스템 파라미터에 대한 자세한 내용은 [Data Design Parameter 사용 예제](/docs/nimoro-studio-data-manage-data-design-parameter-vpc)를 참조해 주십시오. 4. 쿼리 유효성 검사 결과 정보를 확인한 후 **[SAVE AND GO TO NEXT]** 버튼을 클릭해 주십시오. - **Query Check Results** - **실행 Query 확인**: 파라미터의 **Value**가 입력된 실행 쿼리 - **Preview Data**: 불러온 데이터 테이블의 샘플 데이터 #### 2. 데이터 디자인 컬럼 정보 설정(Set Data Column) 데이터 디자인의 컬럼 정보를 입력하는 방법은 다음과 같습니다. 1. 데이터 디자인의 컬럼 정보를 입력해 주십시오. - 데이터 디자인 컬럼 정보 설정에 대한 자세한 내용은 [데이터 디자인 컬럼 수정](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EB%8D%B0%EC%9D%B4%ED%84%B0%EB%94%94%EC%9E%90%EC%9D%B8%EC%BB%AC%EB%9F%BC%EC%88%98%EC%A0%95)을 참조해 주십시오. 2. **[SAVE]** 또는 **[SAVE AND DEPLOY]** 버튼을 클릭해 주십시오. - **[SAVE]** 버튼: 클릭하여 해당 버전 유지하여 저장 - **[SAVE AND DEPLOY]** 버튼: 클릭하여 해당 버전 저장 후 신규 버전 배포 ## 데이터 디자인 세부 정보 확인 데이터 디자인 정보의 세부 정보를 설정하는 방법은 다음과 같습니다. 1. NIMORO 플랫폼에 접속해 주십시오.([NIMORO 플랫폼 접속](/docs/nimoro-access-vpc#NIMORO%ED%94%8C%EB%9E%AB%ED%8F%BC%EC%A0%91%EC%86%8D) 참조) 2. 좌측 메뉴에서 ![i-nimoro_studio](https://cdn.document360.io/6998976f-9d95-4df8-b847-d375892b92c2/Images/Documentation/i-nimoro_studio.png?sv=2026-02-06&spr=https&st=2026-10-26T17%3A11%3A30Z&se=2026-10-26T18%3A11%3A30Z&sr=c&sp=r&sig=7oLXosdrat6EJblJYMtqAZHBR45J47jNGCUmttNr%2B4U%3D)(NIMORO Studio)을 클릭해 주십시오. 3. **Data Manage > Data Design** 메뉴를 차례대로 클릭해 주십시오. 4. 세부 정보를 설정하려는 데이터 디자인 항목 또는 우측의 ![i-nimoro_edit](https://cdn.document360.io/6998976f-9d95-4df8-b847-d375892b92c2/Images/Documentation/i-nimoro_edit.png?sv=2026-02-06&spr=https&st=2026-10-26T17%3A11%3A30Z&se=2026-10-26T18%3A11%3A30Z&sr=c&sp=r&sig=7oLXosdrat6EJblJYMtqAZHBR45J47jNGCUmttNr%2B4U%3D)을 클릭해 주십시오. 5. 데이터 디자인 세부 정보 설정 화면이 나타나면 정보를 확인하고 수정해 주십시오. - **View Data Design** - 데이터 디자인 이름 - **[DATA 조건 전체보기]** 버튼: 클릭하여 [데이터 디자인 전제 조건 조회 및 수정](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EB%8D%B0%EC%9D%B4%ED%84%B0%EB%94%94%EC%9E%90%EC%9D%B8%EC%A0%84%EC%A0%9C%EC%A1%B0%EA%B1%B4%EC%A1%B0%ED%9A%8C%EB%B0%8F%EC%88%98%EC%A0%95) - 추가 기능: 클릭하여 [데이터 디자인 신규 버전 배포](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EB%8D%B0%EC%9D%B4%ED%84%B0%EB%94%94%EC%9E%90%EC%9D%B8%EC%8B%A0%EA%B7%9C%EB%B2%84%EC%A0%84%EB%B0%B0%ED%8F%AC), [데이터 디자인 버전 배포 취소](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EB%8D%B0%EC%9D%B4%ED%84%B0%EB%94%94%EC%9E%90%EC%9D%B8%EB%B2%84%EC%A0%84%EB%B0%B0%ED%8F%AC%EC%B7%A8%EC%86%8C), [데이터 디자인 정보 수정](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EB%8D%B0%EC%9D%B4%ED%84%B0%EB%94%94%EC%9E%90%EC%9D%B8%EC%A0%95%EB%B3%B4%EC%88%98%EC%A0%95), [데이터 디자인 삭제](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EB%8D%B0%EC%9D%B4%ED%84%B0%EB%94%94%EC%9E%90%EC%9D%B8%EC%82%AD%EC%A0%9C) - **Connector**: 커넥터 종류 - **Catalog.DB.Table**: 연결된 Data Catalog 서비스의 데이터베이스의 테이블 이름 - **ID**: 데이터 디자인 목록 번호 - **Creation Type**: 데이터 디자인 생성 방식 - **Import Table**: [외부 DB에서 가져와서 생성](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EC%99%B8%EB%B6%80DB%EC%97%90%EC%84%9C%EA%B0%80%EC%A0%B8%EC%99%80%EC%84%9C%EC%83%9D%EC%84%B1) - **Import Table with Query**: [쿼리로 작성하여 생성](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EC%BF%BC%EB%A6%AC%EB%A1%9C%EC%9E%91%EC%84%B1%ED%95%98%EC%97%AC%EC%83%9D%EC%84%B1) - **Created**: 데이터 디자인 생성 일시(yyyy-mm-dd hh:mm:ss) 및 생성자 이름 - **Last Edited**: 데이터 디자인 마지막 수정 일시(yyyy-mm-dd hh:mm:ss) 및 수정자 이름 - **Last Deployed**: 데이터 디자인 마지막 배포 일시(yyyy-mm-dd hh:mm:ss) 및 배포자 이름 - **Description**: 데이터 디자인 설명 - **Reports Using This**: 해당 데이터 디자인을 사용 중인 리포트 개수 - **Draft Data** / **Deploy V.n** - 배포 전에는 임시 데이터 목록, 최초 배포 이후부터 버전 정보로 타이틀 변경 - 배포 시마다 버전 숫자 추가 - **Browse All Versions**: 배포된 모든 버전 이력 확인 - **[Edit Column]** 버튼: 클릭하여 [데이터 디자인 컬럼 수정](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EB%8D%B0%EC%9D%B4%ED%84%B0%EB%94%94%EC%9E%90%EC%9D%B8%EC%BB%AC%EB%9F%BC%EC%88%98%EC%A0%95) - **[DEPLOY V.n]** 버튼: 클릭하여 [데이터 디자인 신규 버전 배포](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EB%8D%B0%EC%9D%B4%ED%84%B0%EB%94%94%EC%9E%90%EC%9D%B8%EC%8B%A0%EA%B7%9C%EB%B2%84%EC%A0%84%EB%B0%B0%ED%8F%AC) - 전체 컬럼 개수 - **Category**: 컬럼 카테고리 종류 - **COLUMN**: 컬럼 - **Column Name**: 컬럼 이름 - **Data Type**: 컬럼 데이터 유형 - **STRING**: 문자열 - **NUMERIC**: 숫자 - **DATE**: 날짜 - **TIMESTAMP**: 일시(yyyy-mm-dd) - **BOOLEAN**: 이분화된 값(Y 또는 N) - **CODE**: 코드 데이터 - [데이터 디자인 컬럼 수정](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EB%8D%B0%EC%9D%B4%ED%84%B0%EB%94%94%EC%9E%90%EC%9D%B8%EC%BB%AC%EB%9F%BC%EC%88%98%EC%A0%95) 시 변경 가능 - **Change Logic**: 해당 데이터 디자인 내 여러 컬럼을 조합 및 변경하여 새로운 컬럼 생성 가능 - **Tags**: 컬럼 태그 - [데이터 디자인 컬럼 수정](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EB%8D%B0%EC%9D%B4%ED%84%B0%EB%94%94%EC%9E%90%EC%9D%B8%EC%BB%AC%EB%9F%BC%EC%88%98%EC%A0%95) 시 변경 가능 - **Memos**: 컬럼 메모 - [데이터 디자인 컬럼 수정](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EB%8D%B0%EC%9D%B4%ED%84%B0%EB%94%94%EC%9E%90%EC%9D%B8%EC%BB%AC%EB%9F%BC%EC%88%98%EC%A0%95) 시 수정 가능 ## 데이터 디자인 전제 조건 조회 및 수정 데이터 디자인의 전제 조건을 조회하고 수정하는 방법은 다음과 같습니다. 1. NIMORO 플랫폼에 접속해 주십시오.([NIMORO 플랫폼 접속](/docs/nimoro-access-vpc#NIMORO%ED%94%8C%EB%9E%AB%ED%8F%BC%EC%A0%91%EC%86%8D) 참조) 2. 좌측 메뉴에서 ![i-nimoro_studio](https://cdn.document360.io/6998976f-9d95-4df8-b847-d375892b92c2/Images/Documentation/i-nimoro_studio.png?sv=2026-02-06&spr=https&st=2026-10-26T17%3A11%3A30Z&se=2026-10-26T18%3A11%3A30Z&sr=c&sp=r&sig=7oLXosdrat6EJblJYMtqAZHBR45J47jNGCUmttNr%2B4U%3D)(NIMORO Studio)을 클릭해 주십시오. 3. **Data Manage > Data Design** 메뉴를 차례대로 클릭해 주십시오. 4. 세부 정보를 설정하려는 데이터 디자인 항목 또는 우측의 ![i-nimoro_edit](https://cdn.document360.io/6998976f-9d95-4df8-b847-d375892b92c2/Images/Documentation/i-nimoro_edit.png?sv=2026-02-06&spr=https&st=2026-10-26T17%3A11%3A30Z&se=2026-10-26T18%3A11%3A30Z&sr=c&sp=r&sig=7oLXosdrat6EJblJYMtqAZHBR45J47jNGCUmttNr%2B4U%3D)을 클릭해 주십시오. 5. **[DATA 조건 전체보기]** 버튼을 클릭해 주십시오. 6. 데이터 디자인 전제 조건 팝업 창이 나타나면 내용을 확인 또는 수정해 주십시오. 7. **[SAVE]** 버튼을 클릭해 주십시오. ## 데이터 디자인 정보 수정 데이터 디자인 정보를 수정하는 방법은 다음과 같습니다. 1. NIMORO 플랫폼에 접속해 주십시오.([NIMORO 플랫폼 접속](/docs/nimoro-access-vpc#NIMORO%ED%94%8C%EB%9E%AB%ED%8F%BC%EC%A0%91%EC%86%8D) 참조) 2. 좌측 메뉴에서 ![i-nimoro_studio](https://cdn.document360.io/6998976f-9d95-4df8-b847-d375892b92c2/Images/Documentation/i-nimoro_studio.png?sv=2026-02-06&spr=https&st=2026-10-26T17%3A11%3A30Z&se=2026-10-26T18%3A11%3A30Z&sr=c&sp=r&sig=7oLXosdrat6EJblJYMtqAZHBR45J47jNGCUmttNr%2B4U%3D)(NIMORO Studio)을 클릭해 주십시오. 3. **Data Manage > Data Design** 메뉴를 차례대로 클릭해 주십시오. 4. 세부 정보를 설정하려는 데이터 디자인 항목 또는 우측의 ![i-nimoro_edit](https://cdn.document360.io/6998976f-9d95-4df8-b847-d375892b92c2/Images/Documentation/i-nimoro_edit.png?sv=2026-02-06&spr=https&st=2026-10-26T17%3A11%3A30Z&se=2026-10-26T18%3A11%3A30Z&sr=c&sp=r&sig=7oLXosdrat6EJblJYMtqAZHBR45J47jNGCUmttNr%2B4U%3D)을 클릭해 주십시오. 5. **View Data Design**에서 **![i-nimoro_more](https://cdn.document360.io/6998976f-9d95-4df8-b847-d375892b92c2/Images/Documentation/i-nimoro_more.png?sv=2026-02-06&spr=https&st=2026-10-26T17%3A11%3A30Z&se=2026-10-26T18%3A11%3A30Z&sr=c&sp=r&sig=7oLXosdrat6EJblJYMtqAZHBR45J47jNGCUmttNr%2B4U%3D) > Edit Data Design Info**를 차례대로 클릭해 주십시오. 6. 데이터 디자인 정보 수정 팝업 창에서 데이터 디자인 이름 또는 설명을 수정해 주십시오. 7. **[SAVE]** 버튼을 클릭해 주십시오. ## 데이터 디자인 컬럼 수정 데이터 디자인의 컬럼을 수정하는 방법은 다음과 같습니다. 1. NIMORO 플랫폼에 접속해 주십시오.([NIMORO 플랫폼 접속](/docs/nimoro-access-vpc#NIMORO%ED%94%8C%EB%9E%AB%ED%8F%BC%EC%A0%91%EC%86%8D) 참조) 2. 좌측 메뉴에서 ![i-nimoro_studio](https://cdn.document360.io/6998976f-9d95-4df8-b847-d375892b92c2/Images/Documentation/i-nimoro_studio.png?sv=2026-02-06&spr=https&st=2026-10-26T17%3A11%3A30Z&se=2026-10-26T18%3A11%3A30Z&sr=c&sp=r&sig=7oLXosdrat6EJblJYMtqAZHBR45J47jNGCUmttNr%2B4U%3D)(NIMORO Studio)을 클릭해 주십시오. 3. **Data Manage > Data Design** 메뉴를 차례대로 클릭해 주십시오. 4. 세부 정보를 설정하려는 데이터 디자인 항목 또는 우측의 ![i-nimoro_edit](https://cdn.document360.io/6998976f-9d95-4df8-b847-d375892b92c2/Images/Documentation/i-nimoro_edit.png?sv=2026-02-06&spr=https&st=2026-10-26T17%3A11%3A30Z&se=2026-10-26T18%3A11%3A30Z&sr=c&sp=r&sig=7oLXosdrat6EJblJYMtqAZHBR45J47jNGCUmttNr%2B4U%3D)을 클릭해 주십시오. 5. **[EDIT COLUMN]** 버튼을 클릭해 주십시오. 6. 컬럼 목록에서 수정 가능한 컬럼의 각 항목을 클릭해 정보를 설정하거나 입력해 주십시오. - **Data Type**: 컬럼 데이터 유형 - **STRING**: 문자열 - **NUMERIC**: 숫자 - **DATE**: 날짜 - **TIMESTAMP**: 일시(yyyy-mm-dd) - **BOOLEAN**: `Y` 또는 `N` - **CODE**: 코드 그룹 연결 및 설정 - Data Design과 동일한 커넥터를 사용하는 코드 그룹만 선택 가능 - **Code Group** 목록 영역: 코드 그룹 목록에서 연결할 코드 그룹 이름 선택. 코드 그룹 이름으로 검색 가능 - **Detail** 영역 - 코드 그룹 이름 및 설명 - **Info Column**: 선택한 코드 그룹 내의 코드 컬럼(Code Column) 중 리포트에서 KPI 및 디멘션(Dimension)으로 활용할 수 있도록 설정된 info. Column을 확인 - **Join Type**: 코드 테이블 조인을 수행하는 방식 선택 - **Inner**: INNER 조인을 뜻하며, 소스인 기준 테이블과 코드를 조인한 테이블의 중복된 값을 표시 - 결과 값은 소스인 기준 테이블과 코드를 조인한 테이블이 모두 가지고 있는 데이터만 검색됨 - **Left**(기본값): LEFT OUTER 조인을 뜻하며, 소스인 기준 테이블의 값 + 코드를 조인한 테이블과 기준 테이블의 중복된 값을 표시 - 결과 값은 소스인 기준 테이블의 모든 데이터, 소스인 기준 테이블과 코드를 조인한 테이블의 중복되는 값이 검색됨 - **Right**: RIGHT OUTER 조인을 뜻하며, LEFT OUTER 조인과 반대 개념 - 결과 값은 코드를 조인한 테이블의 모든 데이터와 소스인 기준 테이블과 코드를 조인한 테이블의 중복되는 값이 검색됨 - **Full Outer**: FULL OUTER 조인을 뜻하며, 소스인 기준 테이블이 가지고 있는 데이터, 코드를 조인한 테이블이 가지고 있는 데이터 모두 검색 - 사실상 기준 테이블의 의미 없음 - **Join Column Matching**: 조인 조건의 대상이 되는 소스 컬럼(Source Column)과 코드 컬럼(Code Column)을 선택한 후 조인 조건 선택 - 조인 조건: `=`, `>`, `<`, `<=`, `>=` - 조인 조건 설정 필드 내의 소스 컬럼은 해당 Data Design 내의 어떤 컬럼이든 기준으로 삼을 수 있으며, **Add Condition** 버튼을 클릭해 동시 조건으로 다양한 조인 조건 설정 가능 - 조인 조건 설정 필드 내의 코드 컬럼은 [코드 그룹 생성](/docs/nimoro-studio-data-manage-code-group-vpc#%EC%BD%94%EB%93%9C%EA%B7%B8%EB%A3%B9%EC%83%9D%EC%84%B1) 시, Join Key로 설정한 컬럼 중에서 선택해 설정 가능 - **Additional Join Condition (Optional)**: 추가적인 조인 조건 입력 - **Join Column Matching** 조건을 추가로 입력하거나, 코드 테이블에서 특정 데이터만 사용하고자 할 때 사용 - 단, 조인 조건 입력 시 코드 그룹의 컬럼은 반드시 다음 양식으로 입력 - `${joinCodeAlias}.code_column` - `${joinCodeAlias}`: 고정값으로 해당 코드 그룹을 의미 - `code_column`: 조건을 지정할 컬럼명 - <예시> **Join Column Matching** 조건을 추가로 입력: `SQ.col1 = ${joinCodeAlias}.col2` - <예시> 코드 테이블에서 특정 데이터 사용: `${joinCodeAlias}.col2 > 100` - <예시> 2가지 이상의 조건을 복합적으로 사용: `regexp_like(${joinCodeAlias}.col1, '(\d+)') AND SQ.col1 between ${joinCodeAlias}.col2 and ${joinCodeAlias}.col3` - **Tags**: 생성한 태그 연결 - 준비 및 추가 설정된 소스 컬럼 중, 리포트에서 KPI 및 디멘션으로 활용할 컬럼 지정하는 단계 - **Data Design and Column** 영역 - **Data Design** / **Column**: 태그를 연결할 데이터 디자인 이름 및 컬럼 정보 - **Tags** 영역: 태그 목록을 조회하고 선택 - 검색창에 태그 이름, 카테고리, 인덱스를 입력해 검색 가능 - 태그 종류별로 태그 필터링 가능: **All Tag Type**/**Header**/**Basic**/**Date** - 태그 사용 유형별(KPI 및 디멘션)로 필터링 가능: **All Usage Type**/**KPI**/**DIMENTION** - **Header** 태그에 대한 자세한 내용은 [Header 태그](/docs/nimoro-studio-data-manage-tag-vpc#Header%ED%83%9C%EA%B7%B8) 참조 - **Tag**: 태그 종류 - **Usage Type**: 태그 사용 유형(KPI 및 디멘션) - **Descriptions**: 태그에 대한 설명 - **Selected Tags** 영역: **Tags** 영역에서 선택한 태그 목록 - **Tag Name**: 선택한 태그 이름 - **Usage Type**: 선택한 태그의 사용 유형(KPI 및 디멘션) - 기본값 설정은 [태그 추가](/docs/nimoro-studio-data-manage-tag-vpc#%ED%83%9C%EA%B7%B8%EC%B6%94%EA%B0%80) 시 결정되지만, 이 페이지에서도 변경 가능 - **Aggregate**: 선택한 태그의 사용 유형이 KPI인 경우 데이터 집계 방식(Aggregate)을 지정 - 기본값 설정은 [태그 추가](/docs/nimoro-studio-data-manage-tag-vpc#%ED%83%9C%EA%B7%B8%EC%B6%94%EA%B0%80) 시 결정되지만, 이 페이지에서도 변경 가능 - 선택한 태그를 선택 해제하려면 ![i-nimoro_delete](https://cdn.document360.io/6998976f-9d95-4df8-b847-d375892b92c2/Images/Documentation/i-nimoro_delete.png?sv=2026-02-06&spr=https&st=2026-10-26T17%3A11%3A30Z&se=2026-10-26T18%3A11%3A30Z&sr=c&sp=r&sig=7oLXosdrat6EJblJYMtqAZHBR45J47jNGCUmttNr%2B4U%3D) 클릭 - **Memos**: 컬럼에 대한 메모 입력 - 필요한 경우 **[Data Table Reload]** 버튼을 클릭하여 컬럼 목록을 갱신 가능 - **[Add Calculation]**: 변경 조건을 활용하여 계산 컬럼 생성 가능 - ![i-nimoro_delete](https://cdn.document360.io/6998976f-9d95-4df8-b847-d375892b92c2/Images/Documentation/i-nimoro_delete.png?sv=2026-02-06&spr=https&st=2026-10-26T17%3A11%3A30Z&se=2026-10-26T18%3A11%3A30Z&sr=c&sp=r&sig=7oLXosdrat6EJblJYMtqAZHBR45J47jNGCUmttNr%2B4U%3D): 클릭하여 컬럼 삭제 7. 수정 후 **[SAVE]** 버튼을 클릭하여 해당 버전 정보를 저장해 주십시오. ## 데이터 디자인 신규 버전 배포 데이터 디자인의 컬럼을 수정하고 신규 버전으로 배포하는 방법은 다음과 같습니다. 1. [데이터 디자인 컬럼 수정](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EB%8D%B0%EC%9D%B4%ED%84%B0%EB%94%94%EC%9E%90%EC%9D%B8%EC%BB%AC%EB%9F%BC%EC%88%98%EC%A0%95)의 5번 절차까지 따라 주십시오. 2. **[SAVE AND DEPLOY]** 버튼을 클릭해 주십시오. 3. 신규 버전 배포 팝업 창이 나타나면 정보를 입력하고 확인해 주십시오. - **Data Design Information**: 데이터 디자인 정보 - **Data Design**: 데이터 디자인 이름 - **ID**: 데이터 디자인 아이디 - **Catalog.DB.Table**: 데이터 디자인의 데이터베이스의 테이블 이름 - **Deploy Information**: 배포 정보 - **Deploy Version**: 배포 버전 - **Update History**: 배포 이력 - 변동 사항 및 메모 입력 - **Deploy Data**: 배포 데이터 - 자세한 내용은 [데이터 디자인 세부 정보 확인](/docs/ja/nimoro-studio-data-manage-data-design-vpc#%EB%8D%B0%EC%9D%B4%ED%84%B0%EB%94%94%EC%9E%90%EC%9D%B8%EC%84%B8%EB%B6%80%EC%A0%95%EB%B3%B4%ED%99%95%EC%9D%B8) 참조 - **Referenced Report**: 해당 데이터 디자인을 사용하는 리포트 목록 - **No**: 리포트 목록 번호 - **Report Name**: 리포트 이름 - **Last Deployed**: 마지막으로 배포한 일시(yyyy-mm-dd) - **Last Deployer**: 마지막으로 배포한 사용자 이름 4. **[DEPLOY]** 버튼을 클릭해 주십시오. ## 데이터 디자인 버전 배포 취소 데이터 디자인 버전 배포를 취소하는 방법은 다음과 같습니다. 1. NIMORO 플랫폼에 접속해 주십시오.([NIMORO 플랫폼 접속](/docs/nimoro-access-vpc#NIMORO%ED%94%8C%EB%9E%AB%ED%8F%BC%EC%A0%91%EC%86%8D) 참조) 2. 좌측 메뉴에서 ![i-nimoro_studio](https://cdn.document360.io/6998976f-9d95-4df8-b847-d375892b92c2/Images/Documentation/i-nimoro_studio.png?sv=2026-02-06&spr=https&st=2026-10-26T17%3A11%3A30Z&se=2026-10-26T18%3A11%3A30Z&sr=c&sp=r&sig=7oLXosdrat6EJblJYMtqAZHBR45J47jNGCUmttNr%2B4U%3D)(NIMORO Studio)을 클릭해 주십시오. 3. **Data Manage > Data Design** 메뉴를 차례대로 클릭해 주십시오. 4. 배포를 취소하려는 데이터 디자인 항목 또는 우측의 ![i-nimoro_edit](https://cdn.document360.io/6998976f-9d95-4df8-b847-d375892b92c2/Images/Documentation/i-nimoro_edit.png?sv=2026-02-06&spr=https&st=2026-10-26T17%3A11%3A30Z&se=2026-10-26T18%3A11%3A30Z&sr=c&sp=r&sig=7oLXosdrat6EJblJYMtqAZHBR45J47jNGCUmttNr%2B4U%3D)을 클릭해 주십시오. 5. **View Data Design**에서 **![i-nimoro_more](https://cdn.document360.io/6998976f-9d95-4df8-b847-d375892b92c2/Images/Documentation/i-nimoro_more.png?sv=2026-02-06&spr=https&st=2026-10-26T17%3A11%3A30Z&se=2026-10-26T18%3A11%3A30Z&sr=c&sp=r&sig=7oLXosdrat6EJblJYMtqAZHBR45J47jNGCUmttNr%2B4U%3D) > Undeploy**를 차례대로 클릭해 주십시오. ## 데이터 디자인 삭제 데이터 디자인을 삭제하는 방법은 다음과 같습니다. 1. NIMORO 플랫폼에 접속해 주십시오.([NIMORO 플랫폼 접속](/docs/nimoro-access-vpc#NIMORO%ED%94%8C%EB%9E%AB%ED%8F%BC%EC%A0%91%EC%86%8D) 참조) 2. 좌측 메뉴에서 ![i-nimoro_studio](https://cdn.document360.io/6998976f-9d95-4df8-b847-d375892b92c2/Images/Documentation/i-nimoro_studio.png?sv=2026-02-06&spr=https&st=2026-10-26T17%3A11%3A30Z&se=2026-10-26T18%3A11%3A30Z&sr=c&sp=r&sig=7oLXosdrat6EJblJYMtqAZHBR45J47jNGCUmttNr%2B4U%3D)(NIMORO Studio)을 클릭해 주십시오. 3. **Data Manage > Data Design** 메뉴를 차례대로 클릭해 주십시오. 4. 삭제하려는 데이터 디자인 항목 우측의 ![i-nimoro_more](https://cdn.document360.io/6998976f-9d95-4df8-b847-d375892b92c2/Images/Documentation/i-nimoro_more.png?sv=2026-02-06&spr=https&st=2026-10-26T17%3A11%3A30Z&se=2026-10-26T18%3A11%3A30Z&sr=c&sp=r&sig=7oLXosdrat6EJblJYMtqAZHBR45J47jNGCUmttNr%2B4U%3D)을 클릭해 주십시오. 5. ![i-nimoro_delete](https://cdn.document360.io/6998976f-9d95-4df8-b847-d375892b92c2/Images/Documentation/i-nimoro_delete.png?sv=2026-02-06&spr=https&st=2026-10-26T17%3A11%3A30Z&se=2026-10-26T18%3A11%3A30Z&sr=c&sp=r&sig=7oLXosdrat6EJblJYMtqAZHBR45J47jNGCUmttNr%2B4U%3D)을 클릭해 주십시오.